Jump to content

Anschluss des LED Streifens an die Stromversorgung und ans Bricklet


khadoran
 Share

Recommended Posts

Hallo,

 

ich habe versucht, der Anleitung unter "LED Strips" auf der Shopseite http://www.tinkerforge.com/en/doc/Hardware/Bricklets/LED_Strip.html zu folgen:

 

Ich habe den "Step-Down Power Supply" Brick unter ein Master Brick gesteckt.

 

An diesem habe ich eine externe Stromversorgung angeschlossen (Netzteil mit wählbarer Spannung/Stromstärke (z.B. 12V/500mA oder 9V/600mA). Ich habe die 9V Variante gewählt. Ich habe das Teil auch nicht direkt an den LED Streifen angeschlosssen, da das Netzteil keine 5V liefert (nur 4,5V und 6V).

 

Der "Step-Down Power Supply" Brick ist bei mir das, was in dem o.g. Bild als schwarzer Kasten mit "Power Supply" dargestellt ist.

 

Jetzt habe ich die anderen beiden Kabel (CK und SD auf dem LED Strip) an das Bricklet CLK und DAT angeschlossen.

 

Leider ging dabei immer nur das letzte LED an - wenn überhaupt etwas anging -, egal wieviele LEDs ich im Brick Viewer eingestellt habe. Die Farbe entsprach auch nie dem, was ich eingestellt habe und wechselte einmal eher so zufällig. die restlichen LEDs blieben dunkel.

 

Warum kann ich die anderen LEDs nicht ansteuern? Habe ich etwas falsch angeschlossen?

 

Danke.

 

Grüße,

Jens

 

@Tinkerforge: Zudem war es unmöglich, den Streifen in den Silikonschlauch zu schieben, wenn an beiden Enden Stecker dran sind. Ich musste den Stecker einer Seite abschneiden, um das Teil da rein zu kriegen - selbst das war schwierig. :(

 

Link to comment
Share on other sites

@Tinkerforge: Zudem war es unmöglich, den Streifen in den Silikonschlauch zu schieben, wenn an beiden Enden Stecker dran sind. Ich musste den Stecker einer Seite abschneiden, um das Teil da rein zu kriegen - selbst das war schwierig.

 

Ja, das mit dem Schlauch geht nur, wenn der Stecker ab ist. Aber warum zahle ich dann 10,- Euro für Zuschnitt und Stecker anlöten, wenn ich ihn wieder abschneiden und selber anlöten muss (falls die LED's in den Schlauch rein sollen)? Zu dieser Erkenntnis bin ich auch schon gekommen  ???.

Link to comment
Share on other sites

Leider ging dabei immer nur das letzte LED an - wenn überhaupt etwas anging -, egal wieviele LEDs ich im Brick Viewer eingestellt habe. Die Farbe entsprach auch nie dem, was ich eingestellt habe und wechselte einmal eher so zufällig. die restlichen LEDs blieben dunkel.

Schwer zu sagen, hast du evtl. CK und DAT an der falschen Seite angeschlossen? Ansonsten: Kannst du vielleicht ein Foto machen von deinem Aufbau?

 

@Schlauch: Ja, das ist suboptimal. man kann bei einem der Stecker aber die Kontakte rausziehen ohne etwas abzuschneiden, sollten wir auf jeden Fall dokumentieren!

Link to comment
Share on other sites

Schwer zu sagen, hast du evtl. CK und DAT an der falschen Seite angeschlossen? Ansonsten: Kannst du vielleicht ein Foto machen von deinem Aufbau?

Also, ich denke nicht, dass ich etwas falsch angeschlossen habe. Leider war am Kabel die Farbreihenfolge auch anders herum als auf der Shopseite angegeben. :)

 

Hier zumindest mal ein Schnappschuss der Anschlüsse und ein paar Worte dazu:

c6jnl.jpg

 

Am Masterbrick hängen der rote Draht (+) und der schwarze (-), die ganz unten lang gehen. Das ist an der Buchse für die Stromversorgung genauso. die zwei in der Luft hängenden Drähte hatte ich am Input des Bricklets, aber da habe ich im Brickviewer keine Spannung angezeigt bekommen - deswegen hängen sie wieder frei in der Luft.

 

Vom Ledstreifen der rote geht and DAT (SD am Ledstreifen) und der grüne an CLK (CK am Ledstreifen).

 

Der schwarze Draht am Ledstreifen verbindet 5V mit + und der blaue GND mit -.

 

Ich denke, damit sollte jeder Draht am rechten Platz sein. ;)

 

Dass das andere Ende offen hängt, ist aber ok, oder (die LEDs haben ja mal geleuchtet)?

 

Was mich auch etwas irritiert hat, ist die Beschreibung zu GND am Bricklet. Im Text heißt es

"-" is the ground signal line. Ground is necessary to give a reference for the DAT and CLK signals.

 

Jetzt kann ich in Sachen E-Technik nur mit Halbwissen glänzen, aber haben denn die Massen der beiden Stromversorgungen (USB Port und externe Stromversorgung) das gleiche Potential (sie hängen an der gleichen Steckerleiste). Und wenn nicht, hätte das nicht Auswirkung auf die Interpretation der DAT und CLK Signale?

 

Ich habe auch das Gefühl, dass die Daten mit größerer Verzögerung bei dem einen leuchtenden LED ankommen. Hatte gerade im Brickviewer auf Rot+Blau = 255 gesetzt und den Rechner neu gestartet. Ne kurze Zeit später ist das Blau auch angegangen.

 

Was ich gerade fest stelle ist, dass ich alles am OUT des letzten LEDs einspeise. Kann das vielleicht schon der Fehler sein? Ich tausch das mal um und poste dann das Ergebnis ;)

 

Link to comment
Share on other sites

Also es hat nichts gebracht, die Anschlüsse vom OUT des letzten LEDs an die INs des ersten LEDs umzustöpseln. Eine Ansteuerung ist weiterhin nicht möglich.

 

Aber einen seltsamen Effekt hatte ich dabei. Wenn ich die externe Stromversorgung abziehe, gehen plötzlich alle bis auf die letzten 3 an (weiß).

 

Das funktioniert reproduzierbar. Die letzten 3 gehen aber nie an. :(

Link to comment
Share on other sites

Man kann auf dem Bild nicht genau erkennen was wo angeschlossen ist, aber ich glaube du hast nichts bei "-" auf der Input-Seite angeschlossen oder?

 

Du musst mindestens "-" anschließen, ansonsten hat das LED Strip Bricklet keine Referenz für die Datenleitungen. "+" ist nicht notwendig, das wird nur für die Spannungsmessung benötigt.

Link to comment
Share on other sites

Man kann auf dem Bild nicht genau erkennen was wo angeschlossen ist, aber ich glaube du hast nichts bei "-" auf der Input-Seite angeschlossen oder?

 

Du musst mindestens "-" anschließen, ansonsten hat das LED Strip Bricklet keine Referenz für die Datenleitungen. "+" ist nicht notwendig, das wird nur für die Spannungsmessung benötigt.

 

Hurra, das war's :D

 

Danke für den Hinweis! :)

 

Es hilft vielleicht, das auf der Shopseite noch hinzu zu fügen, dass man an das "-" unbedingt das "-" der externen Spannungsversorgung anschließen muss. Das war für mich aus dem einen Satz, den ich auch zitiert hatte, nicht direkt ersichtlich.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...