Jump to content

Red Brick on Raspberry Pi cannot connect to Brick View


greg79
 Share

Recommended Posts

The setup: I have a RPi3 running the Brick Daemon and bricklets connected.The RPi is connected to the local network and so is my terminal (macbook). I have managed to SSH into the RPi successfully and check both the version of the daemon and check the config file (there's none, it uses default values).

Config file '/home/pi/.brickd/brickd.conf' not found, using default values
Using the following config values:
  listen.address           = 0.0.0.0
  listen.plain_port        = 4223
  listen.websocket_port    = 0
  listen.mesh_gateway_port = 4240
  listen.dual_stack        = off
  authentication.secret    = 
  log.level                = info
  log.debug_filter         = 

 

 

Both the RPi and my laptop are connected to the same WIFI access point, Brick Viewer is set to 'localhost' and port 4223. When I hit 'connect', it doesn't yield any error, it just doesn't do anything. The whole setup was tested yesterday and worked fine (I saw the bicklets connected, I could see their UID too).

I have also tried:

 

- restart the daemon on both machines

 

- use a different WIFI network

 

- use '0.0.0.0' as an address instead of 'localhost'

 

What am I doing wrong?

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...