Jump to content

Silent Stepper Model und NEMA 17 Steppermotor


doehlma
 Share

Recommended Posts

Hallo,

 

ich habe mir das Silent Stepper Modul mit dem Nema Stepper Motor with Gearbox 27:1, 3Nm  von Tinkeforge gekauft.

 

Ich kann den Motor ansteuern und er läuft... aber sehr sehr langsam

 

 

Jedoch bin ich Anfänger .. und vielleicht kann mir jemand die Parametereinstellungen geben, wie ich den Motor auf schnellen Hochlauf bei 12 V Ansteuerung bekomme ??

 

Habe ein Video auf Youtube gesehen, wo das normale zu dem Silent Stpper Modul gezeigt wird, und da läuft der Motor viel schneller..

 

Über Rückmeldungen würde ich mich sehr freuen...

 

Danke vorab

 

Gruß

Marcus

Link to comment
Share on other sites

In der Brickv Maske sind so viele Parameter .. dass ich nicht weiss an welchen ich stellen muss damit der Motor schneller läuft.. ich habe auch festgestellt wenn ich bei Steps/s zu weit hochstelle brummt der Mozor nur noch und gewegt sich nicht..

 

Vielleicht kann  mit jemand einmal die Grundfunktionen der vielen Paramter und deren Auswirkungen erklären ?

 

 

Link to comment
Share on other sites

Für den Anfang reicht es wenn du den "Maximum Motor Current" korrekt einstellst, den "Motor Run Current" auf das Maximum stellst und dann mit der Schrittauflösung/Geschwindigkeit/Beschleunigung rumspielst.

 

Wenn der Motor einfach nur brummt kann es sein dass die Beschleunigung zu schnell ist oder auch der Motor nicht so schnell nicht drehen kann mit dem eingestellten Strom.

 

Welche Spannung hat deine Stromversorgung?

Link to comment
Share on other sites

Die Standardeinstellungen sind eigentlich schon OK. Wie schnell dreht denn der Motor wenn er aufhört zu laufen? Du könntest noch einmal "Interpolate" ausstellen damit er auch wirklich Vollschritte macht und im Zweifelsfall die "Thresholds" alle auf 0 setzen damit er nicht den Stealth-Modus verwendet.

 

Ansonsten ist es wenn hohe Geschwindigkeiten/Drehmomente erreicht werden sollen immer vom Vorteil eine möglichst hohe Spannung zu nutzen. Wenn du die Möglichkeit hast könntest du also auch eine höhere Spannung testen (bis zu maximal 46V).

Link to comment
Share on other sites

Hallo Borg,

 

habe mit der Grundmaske angefangen und dann die von Dir aufgeführten Paramter

nach und nach getestet.... der Motor dreht mit 12 V nun wirklich schneller und ich werde dann noch an der Eingangsspannung tunen.. sprich mehr Saft..

 

Danke für deine Hilfe.. so stelle ich mir ein Forum vor .. top :)

 

Gruß

Marcus

Link to comment
Share on other sites

Halo Markus,

 

bis man die richtigen Einstellungen gefunden hat, ist schon was Arbeit nötig.

 

Zum einen hast du ja eine Untersetzung, welche den Motor schon mal "langsamer" macht.

 

Versuche einmal folgende Parameter:

 

Max Velocity -> 300

Acceleration -> Bis oben hin . ( Der Motor beschleunigt nicht mehr langsam sondern gibt sofort Gummi )

Decelaration -> Bis oben hin. Das gleiche gilt jetzt fürs Abbremsen.

 

Step Resolution 1->Fullstep.

 

Die restlichen Werte kannst du erst mal vernachlässigen. Je geringer die die Schrittgröße (Step Resolution) machst, desto langsamer wird der Motor ( bei sonst gleichen Einstellungen )

 

Du kannst z.B. die Schrittgröße auf 1/2 setzen und dafür die Max Velo auf den doppelten Wert stellen.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...