Jump to content

Ladestart nur durch MQTT oder HTTP?


jensstark

Recommended Posts

vor 9 Stunden schrieb rtrbt:

Bei WARP 1 reicht es das automatische Laden abzuschalten. Der Taster kann das Laden nur abbrechen, nicht starten.

Ah! Sehr gut! Dann läuft es wie erwartet!
Ich habe den mich verwirrenden Abschnitt der API-Doku noch mal gelesen, jetzt ist alles klar!
 

charge_release
int	Ladefreigabe. Gibt an, ob automatisch, manuell oder nicht geladen werden kann.

1 - Manuell: Wenn ein Fahrzeug angeschlossen wird, wird es erst geladen, wenn das Laden manuell freigegeben wird. Dieser Modus wird aktiviert, wenn evse/auto_start_charging deaktiviert, der Knopf an der Wallbox gedrückt oder evse/stop_charging aufgerufen wird. Die manuelle Freigabe kann über das Webinterface, oder durch einen API-Aufruf von evse/start_charging erfolgen.

(Wer lesen kann, ist klar im Vorteil.)

Link to comment
Share on other sites

  • 2 months later...
  • 2 weeks later...
Am 7.11.2021 um 10:17 schrieb sahni:

Wie hast du das "Problem" gelöst dass der automatische Ladestart nach einem Neustart des Controllers wieder aktiv ist?

???

Also ich habe den automatischen Ladestart im Webinterface deaktiviert und starte die Ladung ausschließlich über mqtt.

Entweder automatisiert über EVCC (aus dies sendet "einfache" mqtt Befehle an die Warp) oder über openHAB. Für den Winter habe ich eine Regel, den Wagen Nachts zu laden, wenn die Hausbatterie leer ist (um unnätige doppelte Ladeverluste zu vermeiden. Den Wagen lade ich dann mit gemütlichen 7kW, damit die Batterie bei der Kälte keinen Schock bekommt. So ist die Batterie des EV im Winter am Morgen - kurz bevor meine Frau damit losfährt - noch vorgewärmt ;-)

Das der automatische Ladestart nach einem Neustart von alleine wieder aktiv ist, konnte ich nicht beobachten. Wobei ich die Warp - gerade aufgrund des geringen Stromverbrauchs - auch selten ausschalte.

Edited by int5749
Link to comment
Share on other sites

Laut API-Beschreibung (https://www.warp-charger.com/api.html#evse_auto_start_charging) passiert genau das nach einem Neustart. 

Ich habe es so gelöst dass, wenn die Wallbox erkannt wird, wird ein MQTT Kommando gesendet welches den Autostart abschaltet. Zusätzlich mache ich das alle 2 Stunden falls ein Neustart nicht korrekt erkannt wird und nach dem Neustart der Steuerung. 

Vielleicht wäre es aber sinnvoll wenn man diesen Zustand einfach persistent speichern würde in der Wallbox. 

Link to comment
Share on other sites

Nach einem Neustart (Sicherungen aus, oder wie bei mir FI-Schalter ausgelöst ;-) war das automatische Laden (bei meiner WARP2) wieder aktiviert. Dieses Verhalten wurde auch hier https://www.tinkerunity.org/topic/6431-warp-in-home-assistant-via-mqtt-und-http-api/?do=findComment&comment=38116 angesprochen.

Ich finde das nach wie vor unglücklich und wäre mit einem persisten Default Wert glücklicher. Vielleicht wird das ja mit einem FW Update demnächst angeboten.

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 years later...

Hallo zusammen,

vielleicht kann mir einer bei dem Thema noch weiterhelfen. Wir hatten am Wochenende einen Stromausfall und als der Strom wieder kam, fingen auf einmal beiden Wallboxen in der Garage an mit 11kw zu laden. 

Jetzt habe ich den Parameter "Manuelle Lade­freigabe" aktiviert, leider startet jetzt auch die Ladnung nicht mehr per EVCC. Firmware und EVCC sind in der neusten Version installiert. Anhand der Doku sollte es doch funktionieren, da die Ladung per API gestartet wird... Der Status im EVCC ist "Ladebereit. Warte auf Fahrzeug … ".

 

Hat jemand eine Idee oder kann mir einen Tipp geben, was ich falsch machen.

 

danke euch!

Link to comment
Share on other sites

„Manuelle Ladefreigabe“ bedeutet, dass jemand im Webinterface auf „Start“ oder den Taster an der Wallbox drücken muss (sofern der so eingestellt ist, dass eine Ladung damit gestartet werden kann). Das ist also eine zusätzliche Freigabe, unabhängig von EVCC. Üblicherweise ist das nicht das, was du in Kombination mit EVCC haben willst, und du solltest es wieder ausschalten.

Was du brauchst, ist die Externe Steuerung. Ist die aktiviert?

Link to comment
Share on other sites

Hey,

danke für die schnelle Antwort. Ja, die externe Steuerung ist aktiv, so funktioniert auch alles. Ich suche nur einen Weg das die Wallboxen nach einem Stromausfall nicht automatisch anfängt die Autos zu laden. Im aktuelle Fall war zum Zeitpunkt des Stromausfalls keine Ladung aktiv und auch seitens EVCC keine Ladung angefordert. 

danke!

Link to comment
Share on other sites

Das Problem ist vermutlich, dass EVCC die externe Steuerung zwar benutzt, aber nicht einstellt, dass Ladevorgänge blockiert sein sollen, wenn die Wallbox komplett neustartet (wie z.B. nach einem Stromausfall). Im Webinterface der Wallbox gibt es dafür im Moment keine Einstellung, aber du kannst das von Hand machen: Gehe auf http://warp2-abcd/recovery (warp2-abcd durch den Namen deiner Wallbox ersetzen) und trage da im Abschnitt API in das obere Textfeld folgendes ein:

{"method":"PUT", "url":"/evse/external_defaults_update", "payload":{"current": 0,"clear_on_disconnect": null}}

Dann klicke auf "Call API" und dann sollte im unteren Textfeld eine 200 erscheinen.

Ab dann ist bei einem kompletten Neustart die Wallbox blockiert, bis EVCC über die externe Steuerung das Laden freigibt.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...