Jump to content

Issue when disconnecting and reconnecting Hall Effect Bricklet 2.0


arthurPV
 Share

Recommended Posts

Hello

 

I have a problem when I disconnect and reconnect a Hall Effect Bricklet 2.0. After reconnecting, the bricklet is no longer accessible in Brick Viewer (not working in my own program neither). It is detected but when I go to the bricklet tab, I have this message "This bricklet is in booloader mode". This happens whether I disconnect the master brick USB or the 7-poles cable at the master brick side. The only way I found to get the bricklet back is to disconnect and reconnect the 7-poles cable at the bricklet side. This is not practical in my application since the bricklet is not accessible (requires substancial work to reach it) so I would need a more convenient fix for this problem.

 

Ideally, the bricklet should still be funcitonnal after disconnecting and reconnecting the USB. If it is stuck in bootloader mode, there should be a way to reinitialize it without having to phyisically reach the bricklet connector.

 

Is this problem a hardware issue with the bricklet I have? Or is it a repeatable problem? If so, do you have a suggestion for me to try? (hardware or software).

 

Thank you for your help

 

Arth

Link to comment
Share on other sites

This is very strange. There are a few ways a Bricklet can enter the bootloader mode:

  • No firmware was flashed yet
  • A new firmware flashing process is started
  • The flashed firmware is wrong (wrong checksum, firmware of other Bricklet flashed or similar)
  • The bootloader pad on the PCB is shorted

The bootloader pad is the gold pad above the ".com" in this picture: bricklet_hall_effect_v2_top_800.jpg

Can you check that the pad is not shorted? Is it possible that there is some process running in the background that tries to flash a new firmware?

Link to comment
Share on other sites

  • 2 weeks later...

Hi, I have the same problem with this Bricklet. It worked over a few hours without any problems.
But today I come into the same troubles as arthurPV.
I haven't started any firmware flashing or else.
The Bricklet isn't damaged in any way (shortening a circuit or similar...).
Removing the cable did not help. But removing from the magnet helps.
My Bricklet is very close to a magnet before I startup.

Do you have any solutions for this problem?

Thanks in advance 
RBBT

Edited by RBBT
Link to comment
Share on other sites

Hi,
I think that the problem resides in the HAT, but is erratic.
My HAT is mounted on top of an raspi PI 4.
HAT's configuration is like out of the box, I never changed anything.
Firmware Version is 2.0.3.
Raspi ist powered with an original Raspi power supply,
HAT says 5.17Volt.
On the HAT is connected:
1 Compass Bricklet
1 DC Bricklet 2.0
1 Hall Effect Bricklet 2.0
All Bricklets have the latest Firmware.

All LED's are shining, NOT blinking.

In the BrickViewer I pressed the "Sleep Now" Button on the HAT Brick Tab .
After a few seconds the Hall Bricklet began blinking very hectical - not like hartbeat.
but the other Bricklets not! They continue shining.
The compass Bricklet works fine as before, but the Hall Bricklet Tab shows an "Flash"
button.

After the error I started my Java App, an this Exception was presented:
Exception in thread "main" com.tinkerforge.TimeoutException: Did not receive response in time for function ID -1
    at com.tinkerforge.DeviceBase.sendRequest(DeviceBase.java:225)
    at com.tinkerforge.DeviceBase.checkValidity(DeviceBase.java:175)
    at com.tinkerforge.BrickletCompass.setHeadingCallbackConfiguration(BrickletCompass.java:292)
    
The Compass ist the first one that I connect.
    
I tried this a few times again, but unfortunately the problem 
did not occur anymore.

IMHO changes the HAT erratic into sleep mode, but why - I don't know.

Hope this helps.

Best Regards
RBBT

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...