Jump to content

DualRelay & Induktive Lasten - Master Brick reagiert nicht mehr


Nifty
 Share

Recommended Posts

Hallo,

ich betreibe eine kleine Testanlage die aus einem Masterbrick, einem Temperatursensor, dem LCD Display(16x...) und einem DualRelay besteht. Wenn ich ohne Last die Anlage betreibe gibt es keine Probleme. Sobald ich aber mit Last ( das sind in diesem Fall 2 Leuchtstofflampen ) schalte stürzt der Masterbrick spätestens beim 2. Ausschalten ab und muss Reseted werden bevor sie wieder ansprechbar ist. Noch schlimmer: die angehängte NSLU stürzt dabei hin und wieder auch ab, womit ich mir Gedanken darüber mache wie häufig die das aushält bevor da irgend etwas kaputt geht.

 

Hat jemand eine gute Idee wie hier eine zuverlässige und einfache Entstörung stattfinden kann ?

 

 

Link to comment
Share on other sites

Eine galvanische Trennung bietet mir eigentlich schon das Relay - es scheint aber ja so zu sein das die Spitze aus der Spule trotzdem in die Schaltung zurückgesprungen kommt.

 

Ein wenig suchen hat mich auf "Snubber" gebracht die anscheinend zur Beseitigung von Induktiven Ausschaltströmen eingesetzt werden, ich verlinke hier mal auf so ein Ding:

http://www.conrad.de/ce/de/product/503139/RC-GLIED-9902023009

 

Hat jemand damit Erfahrung ?

Link to comment
Share on other sites

Hallo Nifty,

 

ich habe dieses PDF gefunden: http://www.jkmicro.com/inductive_loads.pdf

 

Da findest du auch dieses RC Glied drin wie du es fertig von Finder kaufen kannst. Alternativ versuchst du es mit einem Varistor (auch im PDF genannt).

 

Hier findet man auch eine ordentliche Übersicht an Schutzmöglichkeiten:

http://de.wikipedia.org/wiki/Schutzbeschaltung

 

Halte uns mal auf dem Laufenden.

 

Grüße,

 

Bastian

Link to comment
Share on other sites

Im Englischen Teil dieses Forums gibt es hierzu auch einen Thread

 

http://www.tinkerunity.org/forum/index.php/board,1.0.html

 

Ich warte im Moment noch auf Teile um eine Entstörung auf der Schaltseite des Relais zu bauen - sobald ich hierzu mehr weiß werde ich das hier Posten....

 

Das Problem lässt sich aber nicht mit einem "Step Down Brick" beseitigen.

Link to comment
Share on other sites

Ich hab eine Snubber ausprobiert (C=100nF, R=47 Ohm), sowohl parallel am Ausgang des Relais wie auch direkt parallel zur Last hat es mir nichts gebracht.

 

Dafür hab ich nun einen Defekten Master Brick und eine defekte LCD Anzeige. Um nicht auch noch einen defekten Rechner vorweisen zu können höre ich auf.

 

Ich wähle nun die feige Lösung: Solid State Relay, das müsste übermorgen hier eintreffen.

Link to comment
Share on other sites

  • 2 months later...

So, nachdem ich eine Zeit lang aussetzen musste da andere Dinge vor dem Spieltrieb Vorrang hatten:

 

Ich schalte nun die Neonröhren mit einem IO16 über Solid State Ralays, funktioniert prächtig und ganz nebenbei kann ich nun  16 Verbraucher separat ansteuern - mit einem Master Brick. Wenn ich das mit den Dual Relays versuchen würde müsste ich mindestens 2 Master Bricks nur zum schalten verwenden.

Link to comment
Share on other sites

Solid-State Relais XSSR-DA2420

Steuerspannung 3...32 V-, Steuerstrom 4...20 mA, Schaltspannung 24...240 V~, Schaltstrom max. 20 A. Mit LED-Schaltzustandsanzeige

 

http://www.pollin.de/shop/dt/OTI1OTU2OTk-/Bauelemente_Bauteile/Mechanische_Bauelemente/Relais_Zugmagnete/Solid_State_Relais_XSSR_DA2420.html

 

Das kannst Du direkt am Ausgang der IO Bausteine anschließen und gut ist. Die Lösung gefällt auch mir wesentlich besser als die mit Relais.

Link to comment
Share on other sites

Danke.

 

@tinkerforge: vielleicht ändert ihr die Beschreibung des dualrelais ja um, so dass ihr NICHT empfehlt es für Lampen etc. zu nehmen. und das ganze auch mit rotem rahmen ;)

weil es wird immer welche geben, die damit - weils halt da steht - nicht geeignete lasten damit schalten.

vielleicht ist ja auch noch zwischendurch Zeit ein solid state dual bricklet rauszubringen. Die HardwareÄnderung wäre minimal und an der Software ändert sich garnichts .

Link to comment
Share on other sites

Du darfst den Strom nicht begrenzen - sonst riskierst Du das das Element nicht korrekt arbeitet.

 

Das IO16 kann pro Port 20 mA liefern (kurzzeitig 25mA). Du solltest halt schaun das Du vorne genügend Saft in den Brick rein pumpst.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...