Jump to content

qwt files


kwally
 Share

Recommended Posts

Weiss jemand wo man die dependenciess die mit qt4 qwt gl et cetera finden kann?

Ich reiss mir schon bald die haare aus!! Mir kommt es vor das die ein part von Python sind. Leider kann die Brickview installer nicht finden??

 

Vielen dank

Karl

Link to comment
Share on other sites

Die saga geht weiter. Ich habe hiermit die letzte erro message:

 

  Package python-qt4 is not installed.

brickv depends on python-qt4-gl; however:

  Package python-qt4-gl is not installed.

brickv depends on python-qwt5-qt4; however:

  Package python-qwt5-qt4 is not installed.

brickv depends on python-opengl; however:

  Package python-opengl is not installed.

brickv depends on python-serial; however:

  Package python-serial is not installed.

 

dpkg: error processing brickv (--install):

dependency problems - leaving unconfigured

Processing triggers for desktop-file-utils ...

Errors were encountered while processing:

 

Link to comment
Share on other sites

Danke mOb

 

Das geht leider nicht hiermit das resultat:

 

pi@raspberrypi ~ $ sudo apt-get install python python-qt4 python-qt4-gl python-qwt5-qt4 python-opengl python-serial pyqt4-dev-tools

Reading package lists... Done

Building dependency tree

Reading state information... Done

python is already the newest version.

You might want to run 'apt-get -f install' to correct these:

The following packages have unmet dependencies:

python-opengl : Depends: libglu1-mesa but it is not going to be installed or

                          libglu1

                Depends: freeglut3 but it is not going to be installed

python-qt4 : Depends: libqt4-declarative (>= 4:4.8.0-1~) but it is not going to be installed

              Depends: libqt4-designer (>= 4:4.8.0-1~) but it is not going to be installed

              Depends: libqt4-help (>= 4:4.8.0-1~) but it is not going to be installed

              Depends: libqt4-script (>= 4:4.8.0-1~) but it is not going to be installed

              Depends: libqt4-scripttools (>= 4:4.8.0-1~) but it is not going to be installed

              Depends: libqt4-test (>= 4:4.8.0-1~) but it is not going to be installed

              Depends: libqt4-xmlpatterns (>= 4:4.8.0-1~) but it is not going to be installed

              Depends: libqtassistantclient4 (>= 4.6.3) but it is not going to be installed

              Depends: sip-api-8.1

python-qt4-gl : Depends: libqt4-opengl (>= 4:4.8.0-1~) but it is not going to be installed

python-qwt5-qt4 : Depends: libqwt5-qt4 (>= 5.2.2) but it is not going to be installed

                  Depends: sip-api-8.1

                  Recommends: libqwt-dev but it is not going to be installed

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

pi@raspberrypi ~ $

 

Link to comment
Share on other sites

@kwally: Wir haben es ausprobiert, auf einer frischen Raspberry Pi "Noobs Installation" funktioniert die Anleitung wie sie bei uns in der Dokumentation steht: http://www.tinkerforge.com/de/doc/Embedded/Raspberry_Pi.html#brick-viewer-installieren

 

Falls apt-get die Abhängigkeiten nicht auflösen kann funktioniert nach unseren Tests auch das 'sudo apt-get -f install'.

Link to comment
Share on other sites

Danke Borg, muss was los sein mit meiner NOOB's installation. Ich habe auch eine neue SD card gekauft das NOOBS draufgegeben aber die Raspberry magt die carte nicht und will nichts installieren.Ich glaubte das ich eine loesung hatte mit:

 

sudo apt-get _f install python-twisted aber bekomme ich die folgende error message:

Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main mysql-common all 5.5.33+dfsg-0+wheezy1

  404  Not Found

Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main libmysqlclient18 armhf 5.5.33+dfsg-0+wheezy1

  404  Not Found

Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/m/mysql-5.5/mysql-common_5.5.33+dfsg-0+wheezy1_all.deb  404  Not Found

Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/m/mysql-5.5/libmysqlclient18_5.5.33+dfsg-0+wheezy1_armhf.deb  404  Not Found

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-mi

 

Ich kaufe mir noch eine andere SD carte und versuchs nochmal vom anfang. Die letzte die nicht funktionierte war eine Verbatim. Danke, Karl

Link to comment
Share on other sites

sudo apt-get -f install

Reading package lists... Done

Building dependency tree

Reading state information... Done

Correcting dependencies... Done

The following extra packages will be installed:

  freeglut3 libgl1-mesa-dev libglu1-mesa libglu1-mesa-dev libmysqlclient18

  libpthread-stubs0 libpthread-stubs0-dev libqt4-declarative libqt4-designer

  libqt4-dev libqt4-dev-bin libqt4-help libqt4-opengl libqt4-opengl-dev

  libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql

  libqt4-sql-mysql libqt4-test libqt4-xmlpatterns libqtassistantclient4

  libqtwebkit-dev libqwt-dev libqwt5-qt4 libqwt6 libx11-dev libx11-doc

  libxau-dev libxcb1-dev libxdmcp-dev libxext-dev mesa-common-dev mysql-common

  python-opengl python-qt4 python-qt4-gl python-qwt5-qt4 python-serial

  python-sip qt4-linguist-tools qt4-qmake x11proto-core-dev x11proto-input-dev

  x11proto-kb-dev x11proto-xext-dev xorg-sgml-doctools xtrans-dev

Suggested packages:

  libqt4-declarative-folderlistmodel libqt4-declarative-gestures

  libqt4-declarative-particles libqt4-declarative-shaders qt4-qmlviewer

  firebird-dev libmysqlclient-dev libpq-dev libsqlite0-dev libsqlite3-dev

  qt4-dev-tools qt4-doc unixodbc-dev libxcb-doc libxext-doc libgle3

  python-qt4-dbg python-wxgtk2.8 python-wxgtk2.6 python-wxgtk

The following NEW packages will be installed:

  freeglut3 libgl1-mesa-dev libglu1-mesa libglu1-mesa-dev libmysqlclient18

  libpthread-stubs0 libpthread-stubs0-dev libqt4-declarative libqt4-designer

  libqt4-dev libqt4-dev-bin libqt4-help libqt4-opengl libqt4-opengl-dev

  libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql

  libqt4-sql-mysql libqt4-test libqt4-xmlpatterns libqtassistantclient4

  libqtwebkit-dev libqwt-dev libqwt5-qt4 libqwt6 libx11-dev libx11-doc

  libxau-dev libxcb1-dev libxdmcp-dev libxext-dev mesa-common-dev mysql-common

  python-opengl python-qt4 python-qt4-gl python-qwt5-qt4 python-serial

  python-sip qt4-linguist-tools qt4-qmake x11proto-core-dev x11proto-input-dev

  x11proto-kb-dev x11proto-xext-dev xorg-sgml-doctools xtrans-dev

0 upgraded, 48 newly installed, 0 to remove and 0 not upgraded.

1 not fully installed or removed.

Need to get 703 kB/26.8 MB of archives.

After this operation, 106 MB of additional disk space will be used.

Do you want to continue [Y/n]? y

Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main mysql-common all 5.5.33+dfsg-0+wheezy1

  404  Not Found

Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main libmysqlclient18 armhf 5.5.33+dfsg-0+wheezy1

  404  Not Found

Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/m/mysql-5.5/mysql-common_5.5.33+dfsg-0+wheezy1_all.deb  404  Not Found

Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/m/mysql-5.5/libmysqlclient18_5.5.33+dfsg-0+wheezy1_armhf.deb  404  Not Found

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

pi@raspberrypi ~ $

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...