Jump to content

BrickV Problem


Corius
 Share

Recommended Posts

Hi,

hab das Starter-Packet gerade ausgepackt, Brick angeschlossen per USB (erfolgreich erkannt auch im Gerätemanager), Bricklet Ambient Light 1.1 angeschlossen.

 

Nun starte ich den BrickV, klicke auf "connect" und hätte erwartet, dass ich nun das Brick & Bricklet angezeigt bekomme, das passiert aber nicht.

Das einzige was passiert ist:

Der Button ändert sich von "Connect" auf "Disconnect" und der Button "Advanced Functions" wird aktiviert. Klicke ich auf diesen Button bekomme ich die Meldung "You have to connect at least one Brick". Ich bekomme auch in der Liste nichts angezeigt.

Das Brick hat aber durchgänig das blaue Lämpchen an und als ich es per USB angeschlossen habe, hat er es auch erkannt (Nachdem ich nach BEschreibung den Treiber erfolgreich installiert habe).

Also, wo hab ich noch ein Fehler? Warum bekomme ich meine Bricks/Bricklets nicht angezeigt? Fehlt mir noch ein Schritt?

Hab im Forum leider bisher nichts vergleichbares gefunden :(.

 

BrickD hab ich übrigens auch installiert...

Link to comment
Share on other sites

Installationshinweise von BrickD und BrickV beachtet ? http://www.tinkerforge.com/doc/Software/Brickd.html

Hast Du nach der Installation ein Reboot des Rechners gemacht ?

Ev. am Brick ein Reset auslösen bzw. USB Kabel rausziehen und neuanschließen.

Welcher Brick soll das sein ?

"Advanced Functions" zu Anfang erstmal ignorieren.

Ich vermute mal im Forum gibt es ähnliche Themen :)

Link to comment
Share on other sites

Echt interessantes Problem! Es funktioniert nun:

Was ich geändert habe ist:

Ich bin von einen USB 3.0 Anschluss auf einen USB 2 Anschluss gegangen... Nun klappt es.

Wenn ich wieder auf USB 3 gehe, gehts wieder nicht.

 

Also merken für alle anderen:

USB 2!

Link to comment
Share on other sites

Korrekt. Das ist auch mein Verständnis von USB.

Ich kann nur sagen, dass wenn ich diverse andere Geräte dort anschließe (gerade mal getestet), dass alle Geräte an beiden Anschlüssen optimal funktionieren. Nur wenn ich den Brick an USB 3 anschließe, kriege ich in BrickV weiterhin nichts angezeigt.

Trotzallem ist natürlich nicht auszuschließen, dass mein Lappi n Macke hat (Übrigens Windows 7)

Link to comment
Share on other sites

  • 2 months later...

Corius, das USB 3.0 nicht funktionierte lag daran, dass die Hersteller wie Intel und NEC/Renesas ihre USB 3.0 Controller nicht unter USB in Windows einsortieren sondern unter IUSB3 bzw NUSB3. Dadurch konnte libusb sie nicht finden, da es USB Hubs unter der USB Kategorie erwartet.

 

Brick Daemon 1.0.9 bringt für Windows eine neue libusb Version mit, die Workarounds für diese USB 3.0 Controller enthält. Dadurch werden Bricks jetzt auch gefunden wenn sie an USB 3.0 angeschlossen sind.

 

The_Real_Black, die Stabilität sollte mit Brick Daemon 1.0.9 jetzt auch besser geworden sein, da ich die Verwendung von libusb in brickd etwas verändert habe um mit hot-unplug besser umgehen zu können.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...