Jump to content

Auto startet Ladevorgang nicht mehr mit aktuellster EM/Charger Firmware und EVCC (Hyundai IONIQ)


andyknownasabu

Recommended Posts

Ich habe gerade nachgesehen - bei mir ist in der Konfiguration sowohl "phases", als auch "minCurrent" und "maxCurrent" auskommentiert, da beim Start von evcc in den Logs hier sonst ein Warning steht, dass diese auskommentiert sein müssen. evcc stellt nach und nach auf die Konfiguration per GUI um - ich vermute deswegen. "Auto switching" sehe ich in der GUI "trotzdem".

Ich habe gerade mal wieder "external control" im EM auf "evcc" gestellt, so wie es vorher die ganze Zeit war und funktioniert hat. Bei angeschlossenem Fahrzeug habe ich dann zunächst in der evcc GUI auf "Fast" umgeschalten. Nichts passiert "Waiting for vehicle" (der beschriebene Fehler).

In der evcc GUI von einphasig auf dreiphasig umgeschalten. Nichts passiert.

Dann manuell zurück auf einphasig. Erst hat er kurz geladen. Dann wieder "Waiting for vehicle". Dann plötzlich fängt er an zu laden...

Sollte dazu sagen, dass ich vorher noch die 0.124.1 installiert habe.

 

Leider ist morgen keine Sonne, so dass ich das Überschussladen erstmal nicht testen kann. Aber zumindest kann ich jetzt mit aktiviertem "external control" manuell in evcc das Laden starten. Hoffentlich geht das dann auch wieder automatisch, wenn das nächste mal Sonne ist. Werde berichten...

Edited by andyknownasabu
Link to comment
Share on other sites

@MatzeTF Vielen Dank für dein Testen und die Hinweise, allerdings hatte ich in der evcc.yaml schon „phases:0“ stehen. Bis zum letzten evcc Update mit alter EM Firmware hat das ja auch noch funktioniert.

Lass ich den Eintrag aber drinnen, habe ich in der evcc gui den Menüpunkt „Automatisches Laden“ nicht mehr. Der wird erst angezeigt, wenn der „phases:0“ Eintrag nicht mehr in der yaml drin ist (vgl. Post vorher von mir dazu).

Unabhängig davon führt aber eben das Umschalten der Phasenanfordetung in EVCC bei mir nicht zu einem Phasenumschalten. Das habe ich gestern schon ausprobiert. Der EM verharrt immer nur im Zustand „Keine“, egal, was ich in EVCC drücke.

Grüße.

Knut

Link to comment
Share on other sites

Wie gesagt - laut EVCC Logging Ausgabe sollten diese Option in der evvc.yaml eh nicht mehr stehen. Probier doch auch mal aus, "phases" und "min/maxCurrent" auszukommentieren. Dann EVCC neu starten und die Phasenumschaltung manuell machen in EVCC.

Ob das das Problem bei mir gelöst hat kann ich aktuell noch nicht sicher sagen. Ich hatte dieses Problem vor der neuen Firmware noch nie, aber wenn es damit jetzt geht soll es mir Recht sein.

Link to comment
Share on other sites

Ja, das hatte ich auch schon gelesen und mit beiden Versionen rumgespielt… Ergebnis, siehe oben.

Jetzt mit der neuen 0.124.1 ist es aber wieder anders bei mir. Jetzt kann ich den phases Eintrag drin lassen, trotzdem wird mir der menüpunkt „automatisches Laden“ angezeigt.

Interessant: Auch ich hatte eine min max current Warnung im EVCC Log und den Hinweis, das auszukommentieren, jedoch nicht für die Zeile phases:0.

Das ist alles schon etwas verwirrend muss ich gestehen.

Ps: Am eig. Problem ändert sich nichts, keine Phasenanforderung am EM durch EVCC, egal, was ich einstelle, bzw. drücke.

Edited by der Bauch
  • Sad 1
Link to comment
Share on other sites

Nur zur Sicherheit: Du hast sowohl die aktuelle Firmware für EM (2.0.1) und Charger (2.2.0) installiert? Ich frage, weil ich die aktualisierte Charger Firmware erst übersehen und nur die EM Firmware installiert hatte (ich bin immer noch der Meinung, es sollte eine bessere/einfachere Möglichkeit geben - idealerweise im GUI - von Firmware-Updates zu erfahren. Hier im Forum in dem speziellen Thread schauen oder sich durch die Warp EM/Charger Seiten klicken zu müssen ist nicht sehr anwenderfreundlich).

Ich weiß nicht, ob das wichtig ist bzw. einen großen Unterschied macht. Aber nur um das zumindest mal auszuschließen...

Link to comment
Share on other sites

Klar, kein Problem:

  • WARP on Steroids Firmware 2.2.0-65b21472
  • WEM Firmware 2.0.0-65b21476

Der Vollständigkeit halber muss ich allerdings ergänzen, dass ich meine Firmware selbst baue, da ich diverse Erweiterungen vorgenommen habe (z. B. nachgerüstete CP-Trennung für WARP1, Unterstützung SMA Energy Meter für WEM, ...), die bei eurem Problem m. E. aber nicht relevant sind.

evcc.yaml

chargers:
  - name: wallbox1
    type: template
    template: tinkerforge-warp
    host: 192.168.100.8
    port: 1883
    user: xxx
    password: xxx
    topic: warp2/XSS
    timeout: 30s
    energymanager: wem/26ue

loadpoints:
  - title: WARP
    charger: wallbox1
    mode: off
    enable:
      threshold: 0
      delay: 1m
    disable:
      threshold: 200
      delay: 10m
    guardduration: 30s

 

Gruß Thomas

Link to comment
Share on other sites

On 2/8/2024 at 1:01 PM, rtrbt said:

Kurzes Update dazu: Das Problem scheint ja zu sein, dass der Energy Manager nach einem Neustart blockiert, bis EVCC einmal einen Phasenwechsel anfordert. Das haben wir auf unserer Seite behoben, nach einem Neustart des WEM bleibt die letzte Phaseneinstellung erhalten. Kommt mit Firmware 2.0.2.

Aber Achtung: Das funktioniert nur bei einem einfachen Neustart. Nach einem Firmware-Update oder Stromausfall startet der WEM jetzt im einphasigen Modus. Dann kann man zwar erstmal laden, aber wenn EVCC davon ausgeht, dass gerade dreiphasig geladen wird, wird nie eine Phasenumschaltung auf dreiphasig durchgeführt. Das ist von unserer Seite auch nicht besser zu retten.

Link to comment
Share on other sites

Also bei mir funktioniert das noch immer nicht - und ich möchte nochmal erwähnen, dss ich früher mit der alten Firmware Version (trotz Neustarts etc) dieses Problem nicht hatte.

Heute nacht wollte ich preisgesteuert laden. Threshold für kWh-Preis war eingestellt, Modus auf "Solar". Eigentlich sollte er mit diesem Threshold vier Stunden laden, als ich heute morgen reingeschaut habe, stand wieder "Ready. Waiting for vehicle… ". Ich hatte gestern abend nach dem Anhängen extra  nochmal manuell die Phasenumschaltung gemacht und sichergestellt, dass er einphasig anfängt zu laden. Danach kein Neustart, heute nacht hat er aber trotzdem nicht selbständig angefangen zu laden. Irgendwas liegt da noch im Argen... Nicht, dass wir uns zu früh auf das Problem mit dem Blockieren versteifen und das gar nicht das Problem ist.

UPDATE: Gerade manuell in der GUI auf dreiphasig umgeschalten. Nichts tut sich. Dann wieder auf einphasig und er fängt kurz darauf an zu laden.

Edited by andyknownasabu
Link to comment
Share on other sites

On 2/9/2024 at 5:52 AM, andyknownasabu said:

Also bei mir funktioniert das noch immer nicht

WEM Firmware 2.0.2 ist doch noch nicht veröffentlicht. Ich kann aber bestätigen, dass der WEM mit der aktuellen Entwicklungsversion die letzte Phasenanforderung auch bei einem Neustart behält.

@andyknownasabu, was steht bei dir denn auf der Übersichtsseite und was im Protokoll des WEM, wenn du die Phasenumschaltung in EVCC triggerst? So sollte das aussehen:

IMG_0224.thumb.jpeg.e683316671059a6779a8172abe25d7f4.jpeg
 

Mach doch bitte mal folgenden Test (exakt in dieser Reihenfolge):

  • Neustart WEM
  • Neustart WARP
  • Neustart EVCC
  • Auto verbinden und etwas warten
  • Phasenumschaltung auf 1-phasig durchführen und etwas warten
  • Ladevorgang starten
  • Screenshot der WEM-Übersichtsseite erstellen
  • Ladevorgang beenden
  • Phasenumschaltung auf 3-phasig durchführen und etwas warten
  • Ladevorgang starten
  • Screenshot der WEM-Übersichtsseite erstellen
  • Ladevorgang beenden
  • Protokolle aus WEM und WARP abziehen und hier anhängen

Gruß Thomas

Link to comment
Share on other sites

Wahrscheinlich, weil du bei deinem vorigen Versuch durch eine manuelle Phasenumschaltung evcc dazu gebracht hast, eine Phasenanforderung an den EM zu schicken. Wenn du den EM zwischenzeitlich nicht neugestartet hast, ist die Phasenanforderung weiterhin aktiv und in diesem Zustand sollte es auch weiterhin funktionieren.

Link to comment
Share on other sites

nein, jetzt tut es schon wieder nicht ("Ready. Waiting for vehicle… "). Und ich habe nichts neu gestartet o.ä. Habe einfach den Schwellwert für den Preis angepasst, so dass er jetzt um Mitternacht hätte anfangen müssen. Tut er aber nicht. So sieht das WEM Interface aus:

image.thumb.png.d1792fc4e357bfb88bdb3bfc9f7b0c4c.png

Einmal manuell hin und herschalten (dreiphasig und zurück auf einphasig) und er startet das Laden.

Das ist doch alles Murks, seit einer Woche mache ich damit jetzt schon rum. Diese Probleme hatte ich mit der alten Firmware in Monaten nicht, sehr frustrierend.

Edited by andyknownasabu
Link to comment
Share on other sites

Aus irgendwelchen Gründen steht die Phasenanforderung jetzt wieder auf „Keine“, damit blockiert WEM dann. Ich kann mir aber ehrlich gesagt nicht erklären, wer das wann macht, denn eigentlich sollte EVCC nur eine oder drei Phasen anfordern.

Häng bitte nochmal das aktuelle Protokoll an, dann sollte man zumindest sehen, wann dieser Befehl geschickt wurde…

Link to comment
Share on other sites

Um 2115 Uhr wurde der WEM anscheinend neugestartet, damit war dann wieder keine Phasenanforderung aktiv. Um kurz nach Mitternacht kam dann die manuelle Umschaltung.

Hast du eine Idee, was den Reboot ausgelöst hat? Um 2100 Uhr hat‘s ja funktioniert. Und was sind das für komische „meter_modbus“ und „meter_sunspec“ Fehler? Hattest du die schon immer?

Edited by poohnet
Link to comment
Share on other sites

Hm, seltsam. Keine Ahnung - ich habe ihn jedenfalls nicht neugestartet. Habe extra nichts angefasst, um das um Mitternacht testen zu können...

Aber gut, dann lade ich jetzt mal ein bisschen und beobachte das nochmal beim nächsten Ladevorgang. Gibts ja nicht - warum sollte der EM von selbst neustarten...

Edited by andyknownasabu
Link to comment
Share on other sites

On 2/10/2024 at 12:34 AM, poohnet said:

Und was sind das für komische „meter_modbus“ und „meter_sunspec“ Fehler? Hattest du die schon immer?

Habe den Post gerade noch ergänzt. Vielleicht stürzt der Network-Stack irgendwann ab und der ESP32 macht einen Reboot???

Jedenfalls erklärt das deine Probleme, denn wenn der WEM alle paar Stunden neustartet, dann ist erstmal wieder keine Phasenanforderung aktiv…

Edited by poohnet
Link to comment
Share on other sites

Das sind Fehler, die aufgrund des nicht mehr im Netzwerk auffindbaren Fronius Wechselrichters auftreten. Der schaltet bei fehlender Sonne irgendwann ab. Sollte ich schon immer gehabt haben und hat, wenn es jetzt den ESP zum Absturz bringen sollte, das jedenfalls bisher nicht getan. Gab es in der aktuellen Firmware vielleicht bei der SunSpec Implementierung Änderungen, die dieses Fehlverhalten auslösen können?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...