Jump to content

Chibi connect help


Coldwilson
 Share

Recommended Posts

Hi guys,

 

I've installed latest version on BrickV and flashed two master bricks from 1.0.0 to latest version 1.1.3.

 

I've connected up a chibi to each master brick with one connected to the PC and another to a dc brick for power.  I set one chibi as master and the other as slave exactly as you've shown in your guide.  I can confirm that each chibi is set right as if I plug each master into my main pc the chibi settings details show as I've configured them (and as you've provided in your example). So far, so good.

 

I then connect the IMU up to the remote chibi/master stack, this IMU has been flashed to the latest 1.0.3 as well.

 

When I have them both powered I take a look at the master brick on my Brickv on the main machine.  I don't see the IMU appearing in Brickv but there's nothing in your guides to say whether we'd still see the bricks on the remote stack showing in brickv. 

 

However, I also only see 0db on the chibi and would have expected this to show something else when both are setup and powered on?

 

I try to run a python demo for the IMU on the pc connected to the master brick but it fails to connect to the IMU device.

 

Any suggestions?

 

Thanks

Link to comment
Share on other sites

The IMU should of course show up in the Brick Viewer.

 

Can you try to use the IMU in a stack (remove the Chibi Extension from the Slave Stack and plug a USB cable in the Master).

 

If it doesn't work there either there might be something wrong with the master.

Link to comment
Share on other sites

Tried the IMU stacked with both master bricks (chibi removed) and it works fine with both of them.  It also works fine with both of chibi attached as well so long as it's connected via usb to the machine.

 

It looks like the chibi aren't talking to each other - I'm guessing it should not read 0db?

Link to comment
Share on other sites

It looks like the chibi aren't talking to each other - I'm guessing it should not read 0db?

 

It shouldn't. But the Chibi communication does work if you don't use the IMU, right? That probably means the IMU is not letting some signals through?

 

Can you try to put the Chibi Extension below the IMU in the slave stack?

Link to comment
Share on other sites

I wasn't getting any chibi comms but now I am getting around 57db appearing.  After retrying all connecting to the pc I found that I'd lost the slave settings somehow. What action commits the settings to the chibi memory?  Perhaps I removed power before clicking disconnect - would that explain it?

 

Anyway, now got the 57db signal showing and tried with the IMU and a DC brick both on latest firmware.  Neither are showing up on the pc brickv viewer despite seeing the 57db.  Python code still fails as well.  I've tried moving the imu and dc brick above an below the chibi on the stack.

 

The only thing I can't see at the moment in whether the chibi/master are getting signal as well as the one on the main pc.  The remote one is just connected via the power brick to 5v so it's invisible.  I'll connect it up to a separate pc later so I can see brick viewer in that module separately at the same time.

Link to comment
Share on other sites

Mh, lets make sure everything is connected correctly:

 

Start with one Master Brick and one Chibi Extension, connect to USB and configure as Chibi Master (as shown in the Example).

 

Disconnect this. Take the other Master and the other Chibi Extension, connect to USB and configure as Chibi Slave (as shown in the Example), disconnect USB.

 

Then make the following stack: Step-Down Powersupply -> Master Brick -> Chibi Extension (configured as slave)

 

Plug power into Step-Down Powersupply, wait until the Stack is started (the Master stops blinking)

 

Then plug USB in the other Stack  (Master Brick -> Chibi Extension)

 

If you do this, do you see both Master Bricks in the Brick Viewer?

 

 

If you do:

 

Unplug the USB connection and power and add the IMU Brick to the slave stack, then plug power back in, wait for startup, then plug USB into other stack. What do you know see in the Brick Viewer?

 

Link to comment
Share on other sites

Interesting that there even is a signal strength when you don't see the other master. The signal strength is only measured if packages are received.

 

I am still a bit confused, you wrote before:

I set one chibi as master and the other as slave exactly as you've shown in your guide. I can confirm that each chibi is set right as if I plug each master into my main pc the chibi settings details show as I've configured them (and as you've provided in your example).

 

What did you mean by that? I thought you meant that you had a Chibi connection between two Master?

 

 

Edit:

After retrying all connecting to the pc I found that I'd lost the slave settings somehow. What action commits the settings to the chibi memory?

 

If you go to "Configure Extension Type" and you reconfigure the extension to Chibi, all of the other configurations will be deleted. Perhaps you did that?

Link to comment
Share on other sites

What did you mean by that? I thought you meant that you had a Chibi connection between two Master?

 

I meant that I did the same thing you asked me in your last post.  I have two chibi and two master with a master at the bottom and a chibi on top for each.  So two stacks of master and chibi on top.  I connected each one in turn to the pc to check their settings were as your example and they were.  At the time I was getting 0db which was the first issue I had.  There was never a data connection between the chibi though.

 

If you go to "Configure Extension Type" and you reconfigure the extension to Chibi, all of the other configurations will be deleted. Perhaps you did that?

 

Yes, I did take a look at that box and try to change things.  It's not mentioned in the help guide - that must have been the cause.  They're all set correctly now though.

Link to comment
Share on other sites

I see. One thing i didn't ask yet: Do you have antennas connected to the Chibi Extensions?

 

And if you can test one more thing:

 

If you change the master and slave Chibi Extensions (i.e. you configure the current slave as master and the other way around) does that change something?

 

Edit:

I just reread the thread, what i noticed now: When you say: "another to a dc brick for power" you mean Step-Down Powersupply, right? The DC Brick is a Brick that controls DC Motors, that can't power a stack.

 

And if you use the Step-Down Powersupply, what do you use for power input?

Link to comment
Share on other sites

Yes, got the short antennas on both chibi's.

 

Wow, that final suggestion worked - how strange!!

 

I swapped over the Master bricks and made current master the slave and current slave the master.  It now works perfectly.  Tried it with IMU and DC brick.  Can see both in Brick viewer.

 

I'm very pleased to see it working now but why did that make a difference?

Link to comment
Share on other sites

Wait, what? That works?

 

I was "hoping" that the Master doesn't show up in the Brick Viewer anymore in that case (this would mean that the Chibi Extension must be defect)

 

This is the most confusing thing ever. Well if everything works this way i suppose it is OK.

Link to comment
Share on other sites

Edit:

I just reread the thread, what i noticed now: When you say: "another to a dc brick for power" you mean Step-Down Powersupply, right? The DC Brick is a Brick that controls DC Motors, that can't power a stack.

 

And if you use the Step-Down Powersupply, what do you use for power input?

 

Yes, I meant the power supply brick to connect the other stack.  As it happens I was also using the DC brick (motor driver) to test the stack alongside the IMU (to demonstrate it wasn't just an issue with the IMU).

 

I used a standard transformer connected into the step down power brick.

Link to comment
Share on other sites

I wanted to double check everything so tried things over again.

 

First test:

 

Swapped Master bricks:  moved the remote Master Brick (connected to the slave Chibi) over to the pc and connected up to the master chibi and the pc Master Brick over to the slave Chibi.  Didn't need to reconfigure the Chibi's as they  were the same positions.

 

Result:  Connected up slave to power and master to usb on the pc.  Brick viewer only shows the master brick.

 

Second test:

 

Swap Chibi's:  moved the slave Chibi onto the Master brick connected to the pc and the Chibi on the pc over to the slave.  Then reconfigured the Chibi's to master for the pc connected one and slave for the remote one.

 

Result:  it all works fine again.

 

So here's the sequence of events from when you asked me to swap over Chibi's.  to see the swap around I have marked M1 as Master Brick 1, M2 as Master Brick 2, C1 as Chibi brick 1, C2 as Chibi Brick 2.  Where C1 above M1 is Chibi brick 1 on top of Master brick 1 connected.  The left column represents bricks connected to the pc and the right being the remote powered stack.

 

Step 1 is as it was before you asked me to swap chibi and step 2 is after I swapped them over.

 

1.  C1      C2      original  =  Not working

      M1      M2

 

2.  C2      C1      swap chibi's = Working

      M1      M2

 

3.  C2      C1      leave top Chibis, swap master brick  =  not working

      M2      M1

 

4.  C1      C2      swap Chibi's back, leave masters  =  working

      M2      M1

 

Conclusion from above is that it needs to be C1 with M2 and C2 with M1 to work.  This config works when connected to either the pc or the remote.  So both of the chibi's work in both master or slave positions (after reconfig) but it seems they must only be connected to their partner master bricks.  If they have the other master brick then they stop working.

 

It's weird but hopefully this gives some insight into the issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...