Jump to content

Failed install of brickview


Recommended Posts

For the life of me I can't get brickview to install.I keep getting the same error message:

pi@raspberrypi ~ $ sudo apt-get install python python-qt4 python-qt4-gl python-qwt5-qt4 python-opengl python-serial

Reading package lists... Done

Building dependency tree

Reading state information... Done

python is already the newest version.

python-serial is already the newest version.

python-serial set to manually installed.

You might want to run 'apt-get -f install' to correct these:

The following packages have unmet dependencies:

python-opengl : Depends: libglu1-mesa but it is not going to be installed or

                          libglu1

                Depends: freeglut3 but it is not going to be installed

python-qt4 : Depends: libqt4-declarative (>= 4:4.8.0-1~) but it is not going to be installed

              Depends: libqt4-designer (>= 4:4.8.0-1~) but it is not going to be installed

              Depends: libqt4-help (>= 4:4.8.0-1~) but it is not going to be installed

              Depends: libqt4-script (>= 4:4.8.0-1~) but it is not going to be installed

              Depends: libqt4-scripttools (>= 4:4.8.0-1~) but it is not going to be installed

              Depends: libqt4-test (>= 4:4.8.0-1~) but it is not going to be installed

              Depends: libqt4-xmlpatterns (>= 4:4.8.0-1~) but it is not going to be installed

              Depends: libqtassistantclient4 (>= 4.6.3) but it is not going to be installed

              Depends: sip-api-8.1

python-qt4-gl : Depends: libqt4-opengl (>= 4:4.8.0-1~) but it is not going to be installed

python-qwt5-qt4 : Depends: libqwt5-qt4 (>= 5.2.2) but it is not going to be installed

                  Depends: sip-api-8.1

                  Recommends: libqwt-dev but it is not going to be installed

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

pi@raspberrypi ~ $ sudo apt-get install python python-qt4 python-qt4-gl python-qwt5-qt4 python-op

Has anyone got a solution? Much appreciated

Link to comment
Share on other sites

I keep getting the same error message no matter what permutation I try. This apparently stopd my Brickv from installing.Her it is

 

The following packages have unmet dependencies:

brickv : Depends: python-qt4 but it is not going to be installed

          Depends: python-qt4-gl but it is not going to be installed

          Depends: python-qwt5-qt4 but it is not going to be installed

          Depends: python-opengl but it is not going to be installed

pm-utils : Depends: powermgmt-base but it is not going to be installed

            Recommends: vbetool but it is not installable

            Recommends: hdparm but it is not going to be installed

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution)

Are you there Remote Control?

 

Link to comment
Share on other sites

Danke Loetkolben. Ja hab ich schon probiert. Aus meiner verzweiflung habe ich mein 16 Gig Sandisk formatted and started all over again following judiciously the instruction on Tinkerforge. I thought I had it; when I got to the stage of answering wether or not I agree to surrendering some 550 odd meg of disk space. I happily selected y for yes !!! wait for it! I got and "abort" Why for heavens sake?? I thought perhaps answering n for no would do it; but no it resulted in the same "abort" responds. I have a newly formatted 60 gig Sandisk?

 

Sorry, I am not sure if you prefer english. Let me know. I live in Brisbane/Australia. Though I do speak German.

 

Cheers

Karl

Link to comment
Share on other sites

I use Python 3.2 I think. The one that installs from NOOBS, it just offers Python at install doesn't say which version. The SD card is a 16 gig Sandisk Xtra speed. I have gone back and re-formatted and re-installed NOOBS twice. It just will not install the qt4 qt5gl et cetera. The brickdeamon installed okay. There is also a Brickv Icon in my "other" directory but clicking on it produces nothing, it is just a shortcut, that seems to be leading nowhere. Thanks for trying. The -f switch seems to make no difference.

Link to comment
Share on other sites

It doesn't seem to matter what call I make the same error report appears:

 

The following packages have unmet dependencies:

brickv : Depends: python-qt4 but it is not going to be installed

          Depends: python-qt4-gl but it is not going to be installed

          Depends: python-qwt5-qt4 but it is not going to be installed

          Depends: python-opengl but it is not going to be installed

          Depends: python-serial but it is not going to be installed

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

# note: the –f switch makes no difference

I got the same message when trying to install geany.i.e.

sudo apt-get install geany.

 

Thank you chaps

Link to comment
Share on other sites

The following proved to resolve this issue:

 

Run this first:

sudo apt-get install libusb-1.0-0 libudev0 pm-utils

 

Wait till this process finishes !! then run:

wget

http://download.tinkerforge.com/tools/brickd/linux/brickd_linux_latest_armhf.deb

sudo dpkg -i brickd_linux_latest_armhf.deb

 

Again, wait till this is done, then run:

sudo apt-get -f install python python-qt4 python-qt4-gl python-qwt5-qt4 python-opengl python-serial

 

Wait till done, then run:

wget http://download.tinkerforge.com/tools/brickv/linux/brickv_linux_latest.deb

sudo dpkg -i brickv_linux_latest.deb

 

Cheers

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...