Jump to content

Issues with Brick Daemon


Recommended Posts



I'm a complete novice as far as Thinkforge products go. I recently bought the Brick IMU and have been trying to test it through Brick Daemon but haven't had much success. I have not been able to open the program: shortly after I launch the installer, it notifies me installation is complete but nothing else happens, and I haven't been able to launch or open the program. I should mention that I've upgraded to OS X El Capitan yesterday.


Also, I've tried every sort of installation method, including from source.


Any help or insights are much appreciated. I plan on using it with either the MATLAB or python bindings, which I have recently installed.


Thanks in advance.



Link to comment
Share on other sites

First of all, you need to use Brick Daemon 2.2.2 for OS X El Capitan. Apple changed things in El Capitan that makes the brickd installer of earlier versions fail silently. This is fixed in brickd 2.2.2.


Brick Daemon itself has no GUI. It runs in the background and translates between USB and TCP/IP. You can look at its log file at /var/log/brickd.log and you can check that is properly running as a launchd daemon with this command in a terminal:


sudo launchctl list | grep brickd


It should print one line with three values like this (the first number can be different):


1511   0   com.tinkerforge.brickd


If it prints nothing, then brickd is not properly installed. If the first value is not a number but a dash (-) then brickd is not running. In that case you can start it with:


sudo launchctl start com.tinkerforge.brickd


The GUI program for testing Bricks and Bricklets is called Brick Viewer. After you installed Brick Viewer, start it and click its "Connect" button. Then Brick Viewer connects to Brick Daemon over TCP/IP and Brick Daemon translates this to USB for the Bricks and Bricklets connected to USB. Now you should see your Bricks and Bricklets in Brick Viewer.

Link to comment
Share on other sites

Thanks for the response and for the info. I've got Brick Daemon 2.2.2 installed and running (confirmed by the terminal output):


22510   0   com.tinkerforge.brickd


However, when I run Brick Viewer (version 2.2.7) the Brick IMU 2.0 is not listed, hence I cannot connect to it. The following error appears: "Could not connect. Please check host, port, and ensure Brick Daemon is running."


My settings: Host: localhost, Port: 2443 (Default, should it be changed?), and I can assure the IMU 2.0 is connected properly since it appears on Mac's system report.


Any further help would be much appreciated.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...